Windows Clustering

Windows Clustering provides three different, but complementary, clustering technologies. The clustering technologies, which ship in a number of different products, can be used separately or combined to provide scalable and highly-available services.
Clustering Technology | Network Load Balancing (NLB) clusters | Component Load Balancing (CLB) clusters | Server clusters
Available in ... | XOX; XOX; XOX; and XOX | Microsoft Application Center 2000 | XOX, and XOX
Maximum number of nodes | 32 | 12 | 8
Application | Load balancing Transmission Control Protocol (TCP) and User Datagram Protocol (UDP) traffic | Single point of management and configuration for Web farms | Failover and failback of applications
Specialized hardware required? No

Note

  • If you use teaming network adapters, you must select network adapters listed in the Windows Catalog. For more information, see Network Load Balancing system requirements and the compatibility information in Support resources.
No Yes

To confirm that your server cluster hardware is designed for XOX, or XOX, see the compatibility information in Support resources.
Typical deployments | Web servers, Microsoft Internet Security and Acceleration (ISA) Server, virtual private networks, Windows Media™ servers, Mobile Information servers, Terminal Services | Web farms | MS SQL Server, MS Exchange Server, file and print servers, Message Queuing
Stateful or stateless? | Stateless | Stateless | Stateful

Important

  • Microsoft will not support the configuration of server clusters and Network Load Balancing clusters on the same server. For more information about how the Windows Clustering technologies can be combined in a multitiered approach to provide highly available services, see "Planning for High Availability" in the Microsoft Windows Server 2003 Deployment Kit at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/) In addition, see "Server Clusters and Network Load Balancing" in the Microsoft Windows Server 2003 Resource Kit at the Microsoft Windows Resource Kits Web site. (http://www.microsoft.com/)

  1. Network Load Balancing clusters. Network Load Balancing clusters provide scalability and high availability for TCP- and UDP-based services and applications by combining up to 32 servers running XOX; XOX; XOX; or XOX, into a single cluster. By using Network Load Balancing to build a group of cloned, or identical, clustered computers, you can enhance the availability of these servers: Web and File Transfer Protocol (FTP) servers, ISA servers (for proxy servers and firewall services), virtual private network (VPN) servers, Windows Media servers, Terminal Services over your corporate LAN.

    You can install Network Load Balancing clusters through Network Connections or by using the Network Load Balancing Manager. For more information about Network Load Balancing clusters, see Network Load Balancing overview.

  2. Component Load Balancing clusters. Component Load Balancing clusters provide high scalability and availability by enabling COM+ applications (for example, a shopping cart application on an e-commerce Web site) to be distributed across multiple servers. For more information, see the documentation for Microsoft Application Center 2000 in Microsoft TechNet at the Microsoft Web site.(http://www.microsoft.com/)

    Important

    • Component Load Balancing clusters is a feature of Microsoft Application Center 2000. It is not a feature of XOX; XOX; or XOX.

  3. Server clusters. Server clusters provide high availability for applications through the failover of resources. Server clusters focus on preserving client access to applications and system services, such as Microsoft Exchange for messaging, Microsoft SQL Server for database applications, and file and print services.

    Server clusters can combine up to eight nodes. In addition, a cluster cannot be made up of nodes running both XOX, and XOX. In server clusters with more than two nodes, all nodes must run XOX, or XOX, but not both.

    By default, all clustering and administration software files are automatically installed on your computer when you install any operating system in the Windows Server 2003 family. For more information about server clusters, see Understanding server clusters.

  • For conceptual and procedural information on Network Load Balancing clusters, see Network Load Balancing clusters.
  • For conceptual and procedural information on server clusters, see Server clusters.
  • For guidelines on securing a Network Load Balancing cluster, see Best practices.
  • For guidelines on securing a server cluster, see Best practices for securing server clusters.


Compile Date

 Compile Date: 2003-01-04